1

Closed

Add symbols for nuget packages

description

I'm trying to track down a problem in an app using Okra but to do that I need to debug into the source.

Since I've installed via NuGet it'd be cool if the symbols were also resolvable via NuGet as outlined here - http://docs.nuget.org/docs/creating-packages/creating-and-publishing-a-symbol-package
Closed Aug 27, 2012 at 9:20 AM by AndyWilkinson
Debug symbols now published automatically on submission to NuGet.

comments

AndyWilkinson wrote Aug 16, 2012 at 12:30 PM

I will look into co-releasing the source symbols with the next release of the Okra App Framework (most likely the Win8 RTM release so hopefully not too far off!).

As a workaround for the meantime you can download the current source package from CodePlex (http://okra.codeplex.com/releases/). If you build this you can remove the existing NuGet package reference and add the resulting DLLs as "Browse to" references (as well as the relevant version of MEF).

Sorry for the inconvinience caused and I'll try to get the source symbols up soon.

Andy

slace wrote Aug 16, 2012 at 11:24 PM

I'm running Win8 RTM already and I can let you know that there's no problems running Okra apps.

All I've done is installed RTM, installed VS, cloned my project and run it. No change to any files (remember Win8 RC and VS2012 RC both had a go-live license so it shouldn't break anything or require a recompile)

AndyWilkinson wrote Aug 17, 2012 at 9:13 AM

That's good to know. The change list didn't seem to have anything that would impact Okra so I was hopeful. I've downloaded the RTM bits so will be installing them soon.

AndyWilkinson wrote Aug 26, 2012 at 9:24 PM

I've just pushed v0.9.4 of the Okra App Framework onto CodePlex and NuGet. I should have enabled the debug symbols for this release - let me know if this works okay for you. I've also corrected a mistake in the NuGet configuration files that should now show better exception messages which should help.

As an aside, have you managed to solve the issues you were having? If you want to discuss them further you can contact me directly via the contact link on my blog (http://andyonwpf.blogspot.com).

Andy

slace wrote Aug 26, 2012 at 11:20 PM

Works like a charm.

The problem turned out to be unrelated to Okra, it was actually an OS-level bug in Win8 RC related to navigation. RTM fixed it so it's all good.

AndyWilkinson wrote Aug 27, 2012 at 9:18 AM

Great - Thanks for letting me know. Good to hear your problem was solved too.
I'll close out this issue.

Andy